Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; AntiBotCaptcha has a deprecated constructor in /homepages/8/d680172117/htdocs/QA/qa-plugin/q2a-captcha-antibot-master/AntiBotCaptcha.php on line 22
DIY quad copter using Arduino - Electronoobs Q&A

Welcome to Electronoobs Q&A, where you can ask questions and receive answers from other members of the community.


PCBWay Ad

Categories


+3 votes
I had built the quadcopter like what you had done but I had a problem, it keep spinning clockwise went trying to flying up. This happened is because two motors were stopped. From the multiwiiconf, I saw the motor speed was below the min throttle of the ESC. I had calibrated the ESC too and No bad connections.

The only difference was I am using the code from github. Is that the reason? I am eagerly wanted to finish this project.
asked in Arduino by (250 points)

2 Answers

+1 vote
 
Best answer
I found the problem besides the firmware. It was the faulty ESC controllers. I had replaced one of the suspicious broken ESC and finally it works!! Thanks again for the help.
answered by (250 points)
selected by
+1 vote
When you select IMU board, what configuration did you selected? What is your minthrottle and min command? Did you set the range of all ESCs from 1000 to 2000us?

Keep up!
answered by (27k points)
I use NanoWii for the IMU board.
minthrottle at 1100 and min command at 1064.

I had set the range 1000 to 2000us for all the ESC.

Tonight will try again with the code from you. Thanks.
I had tried your version and is working great. At last the yaw spinning is not happened any more and I also had identified one of my ESC seems broken. The only ESC seems will lost sync and went to the maximum speed. All the other three ESC behaves well and only one is still running the motor at maximum while others I can disarm it. Going to replace the broken ESC and see what's next. Thanks for the guide and help. I am very glad to discover your page and the videos.
...