Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; AntiBotCaptcha has a deprecated constructor in /homepages/8/d680172117/htdocs/QA/qa-plugin/q2a-captcha-antibot-master/AntiBotCaptcha.php on line 22
1 of my esc can't work normally - Electronoobs Q&A

Welcome to Electronoobs Q&A, where you can ask questions and receive answers from other members of the community.


PCBWay Ad

Categories


+1 vote
best regards sir, I am from Indonesia, I want ask and need help about quadcopter with arduino and MULTIWII. I have done and run the whole series of tutorials and lessons that electronoobs provide both from youtube videos and electronoobs website. but I have constraints. one motor and my esc is not working normally while the other 3 is working normally. one esc has a problem on the minimum thortle, if 3 esc the other is given input 1000-1200, they can work normally. but esc 1 is not. I have also done an esc calibration on each esc as electronoobs do by giving 1000 values ​​as a minimum value and 2000 as the maximum throttle, but still like that. I have a trial video that I did, but I am confused how to send to you by which email? . the video explains for more details of the problems that I face. I sincerely ask your help to solve my problem in this project, my respect. Bogor - Indonesia
asked in Arduino by (250 points)

1 Answer

+1 vote
 
Best answer
Hi there. First (I know you've dnne that) but make sure that all ESCs have same range calibrated 1000 to 2000us.

So, motor 1 is not working but 2,3 and 4 yes. Try putting the signal from 2 to motor 1 and if it is working then is noit the motor problem. If it is still not working then is the ESC or motor and you should recalibrate or maybe have damage parts.

If is the multiwii that fails, when connected to multiwii make sure you calibrate the Accelerometer and that the drone is flat on the ground so all the motors should have even values.

Keep up! (BTW, I answer questions only when I have a bit of free time so I might answwer late)
answered by (27k points)
Thank you sir, I have done what you suggest. I do re-calibration esc, all running normally. but still there is a problem esc, then I try to replace esc for motor 1 with esc belong to motor 2, and the result is work well. so while I conclude that the esc is problematic. I use esc 30A SimonK Brushless, thankyou very much about your help

here is picture of MULTIWII aplication on my quadcopter, there are not stabilized value on all of esc and motor. for this problem i still confused, please tell to me about this sir, really need your help, thankyou sir

Thank you sir, I have done what you suggest. I do re-calibration esc, all running normally. but still there is a problem esc, then I try to replace esc for motor 1 with esc belong to motor 2, and the result is work well. so while I conclude that the esc is problematic. I use esc 30A SimonK Brushless, thankyou very much about your help

here is picture of MULTIWII aplication on my quadcopter, there are not stabilized value on all of esc and motor. for this problem i still confused, please tell to me about this sir, really need your help, thankyou sir

The photo looks ok. It might be the ESC with the problem...
sir, i have a new problem, my esc can work normally, but when i give ful throtle, my quad can't flyig up, i use f450 frame sir, i have setting PID P roll , pitch = 4.2
P yaw = 7.8

I roll , pitch = 30
I yaw = 45

D roll, pitch = 20
D yaw = 0
What do you mean can't fly up¿ Desn't have enough power? is too heavy?
I am also confused by the problems that I face, but that there is such, when I raise the thortle to maximize thortle, quadcopter will not lift but brushles spin faster, I do not add aapun in the frame, only 2200mah and arduino measurements according to the tutorial pack , please help sir, thank you
...