54 Online
4 Member And 50 Guest
Today Visits : 6749
Yesterday Visits : 29386
All Visits : 1979767

Welcome to Electronoobs Q&A, where you can ask questions and receive answers from other members of the community.



Categories


1 like 0 dislike
Hi,

so I am using an Arduino Nano with Mulitiwii code from Google code Archive for my Arduino drone as you have said in the instructions. My receiver is a PWM receiver. I have connected all the ports to the correct pins as specified and the motors are arming, but the drone is not taking off. Everything else is working, as I tilt the gyroscope, the motors change pitch but even if I put the transmitter at full throttle, it doesn't take off. I thought my batteries were low but I charged them but still the same problem is happening.

I am using some unbranded 30A ESC with A2212 1000KV motors. https://www.amazon.in/Robotbanao-Outrunner-Controller-Multi-Copter-Quadcopter/dp/B07D4PFYFJ/ref=sr_1_9_sspa?s=industrial&ie=UTF8&qid=1542246336&sr=1-9-spons&keywords=a2212+1000kv+brushless+motor+for+rc+airplane+quadcopter&psc=1- the link where I bought it from.

What troubleshooting should I do for this?

Also would like to know if I can use Arduino Mega for this project? Will it give a better more stable drone? How should I use the Arduino Mega for this Arduino drone?

Thank you, waiting for your reply.
in Arduino by (130 points)
edited by

1 Answer

0 like 0 dislike
Do you arm the motors and they start to spin at low speed and when you increasae throttle they won't increase the speed or the motors won't spin at all?
by (34.8k points)
When I arm the motors, they spin and as I increase the throttle, the motors increase in RPM but the drone does not take off.
Check rotation of moters and propellers if ccw propellers and mounted on CW motors and vice versa. I have noticed it many times. This is a common mistake.
...