Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; AntiBotCaptcha has a deprecated constructor in /homepages/8/d680172117/htdocs/QA/qa-plugin/q2a-captcha-antibot-master/AntiBotCaptcha.php on line 22
DIY ESC: low voltage problem - Electronoobs Q&A

Welcome to Electronoobs Q&A, where you can ask questions and receive answers from other members of the community.


PCBWay Ad

Categories


+2 votes

Hi, please, can you help me urgently?  As this ESC is considered to be my graduation project.  

I have tried your ESC code and hardware and I had faced some problems.

  • The voltage at motor terminals is very low (with 12V DC charger) it’s nearly 0.9 V! can I know why?
  • I have replaced the IR2301 component with 4n35 Optocoupler, is that okay?
  • The voltage divider output is very small! Due to the low voltage at motor, so it can’t detect ZCP, is there any solution.

Thanks in advance.

asked by (200 points)

1 Answer

0 votes
Use the osciloscope and test if the signals from your optocouplers are activating the MOSFET gates. If not, then is the driver problem. Keep up!
answered by (30.9k points)
Hmm? are u using same MOSFETS as in my tutorial? Are the Gate drain and source the same as in my tutorial? Maybe the transistors got burnned...
Actually, everything is okay and same as in your tutorial. But the problem is with the low voltage, hence, arduino can’t detect ZCP as the input analog voltage is very low!!
Another important question, what is the ground of the voltage dividers?
 

thanks in advance,
ground is always ground. There are no 2 grounds. Only one!
I can’t catch up with you sorry.

There are:

Arduino ground and the inverter DC voltage(-ve).

Am i correct?

And if not, where is the ground that i can connect the voltage dividers with it?

Thanks so much for your attention.
...